
On 06/20/2012 03:15 AM, Jim Lin wrote:
A known hardware issue of USB1 port where bit 1 (connect status change) of PORTSC register will be set after issuing Port Reset (like "usb reset" in u-boot command line). This will be treated as an error and stops later device enumeration.
Therefore we clear that bit after Port Reset in order to proceed later device enumeration.
Signed-off-by: Jim Lin jilin@nvidia.com
Acked-by: Stephen Warren swarren@wwwdotorg.org
But a couple of nits below,
diff --git a/drivers/usb/host/ehci-tegra.c b/drivers/usb/host/ehci-tegra.c
+/*
- A known hardware issue where Connect Status Change bit of PORTSC register
- of USB1 controller will be set after Port Reset.
- We have to clear it in order for later device enumeration to proceed.
- */
It might be worth adding a note in that comment saying that this overrides a weak symbol in ehci-hcd.c so that people know where it's called.
+void ehci_powerup_fixup(uint32_t *status_reg, uint32_t *reg) +{
- uint32_t my_reg;
I would rename this variable just "reg"; the variable doesn't belong to a person, and names with "my" in just make me cringe.