
On Mon, 16 Feb 2009, Wolfgang Denk wrote:
Dear ksi@koi8.net,
In message Pine.LNX.4.64ksi.0902121417310.21067@home-gw.koi8.net you wrote:
...
-int i2c_read (uchar chip, uint addr, int alen, uchar * buffer, int len) +static int omap1510_i2c_read (uchar chip, uint addr, int alen, uchar * buffer, int len) { int i;
if (alen > 1) {
printf ("I2C read: addr len %d not supported\n", alen);
printf ("%s: addr len %d not supported\n", __FUNCTION__, alen);
return 1; }
if (addr + len > 256) {
printf ("I2C read: address out of range\n");
printf ("%s: address out of range\n", __FUNCTION__);
These are changes really to the worse: instead of
I2C read: address out of range
we now get
omap1510_i2c_read: address out of range
More difficult to read, higher memory footprint.
Please revert this.
No problems, will do.
--- ****************************************************************** * KSI@home KOI8 Net < > The impossible we do immediately. * * Las Vegas NV, USA < > Miracles require 24-hour notice. * ******************************************************************