
On Wed, May 3, 2017 at 5:36 AM, Simon Glass sjg@chromium.org wrote:
Hi Andy,
On 24 April 2017 at 02:04, Andy Shevchenko andy.shevchenko@gmail.com wrote:
On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass sjg@chromium.org wrote:
At present this code is inline. Move it into a function to allow it to be used elsewhere.
Signed-off-by: Simon Glass sjg@chromium.org
+static int blk_next_free_devnum(enum if_type if_type) +{
int ret;
ret = blk_find_max_devnum(if_type);
if (ret == -ENODEV)
return 0;
else if (ret < 0)
Useless 'else'.
return ret;
else
Ditto.
return ret + 1;
+}
I think it is clearer with these. At least, I would ask for them to be added if they were missing.
Really? It's just noise in the code which makes it harder to read. In Linux kernel we remove that. If U-Boot has the above style kinda mandatory I would be really surprised.
What do you think of this series as a whole?
It was a while ago. So, if there were no comments from me, that means I have nothing to argue of.