
Hello Tom,
please pull from u-boot-i2c.git master
There is a compile fix from Mario, also DM support for fsl_i2c, DM support for TI PCA954X muxes from Michal, a check for the enable status register in the designware i2c driver from Stefan and a fix for the mvtwsi driver, which now does not need writting a global variable.
buildman says no errors introduced, so I think its ready for mainline ...
The following changes since commit aeaec0e682f45b9e0c62c522fafea353931f73ed:
Prepare v2016.05 (2016-05-16 10:40:32 -0400)
are available in the git repository at:
git://git.denx.de/u-boot-i2c.git master
for you to fetch changes up to d6b7757e41d22e08f21f58d3fe9183a150582f61:
i2c: mvtwsi: Eliminate twsi_control_flags (2016-05-17 08:32:02 +0200)
---------------------------------------------------------------- Chris Packham (1): i2c: mvtwsi: Eliminate twsi_control_flags
Michal Simek (4): i2c: cdns: Read address from DT in ofdata_to_platdata i2c: cdns: Moving speed setup from probe to set_bus_speed function i2c: cdns: Support different bus speeds i2c: muxes: Add support for TI PCA954X mux
Stefan Roese (4): i2c: designware_i2c: Optionally check enable status register i2c: Add entry for Designware I2C driver in Kconfig i2c: config: Move SYS_I2C_DW to Kconfig i2c: Select SYS_I2C_DW_ENABLE_STATUS_UNSUPPORTED for SPEAr
mario.six@gdsys.cc (9): dm: fsl_i2c: Rename I2C register structure dm: fsl_i2c: Use clearer parameter names dm: fsl_i2c: Reword and clarify comment dm: fsl_i2c: Remove unnecessary variable dm: fsl_i2c: Rename probe method dm: fsl_i2c: Rename methods for reading/writing data dm: fsl_i2c: Prepare compatibility functions dm: fsl_i2c: Factor out adap parameter dm: fsl_i2c: Enable DM for FSL I2C
arch/m68k/include/asm/fsl_i2c.h | 2 +- arch/powerpc/include/asm/fsl_i2c.h | 12 +++- arch/powerpc/include/asm/immap_85xx.h | 4 +- arch/powerpc/include/asm/immap_86xx.h | 4 +- board/keymile/km83xx/km83xx_i2c.c | 28 +++++---- configs/axs101_defconfig | 1 + configs/axs103_defconfig | 1 + configs/socfpga_arria5_defconfig | 1 + configs/socfpga_cyclone5_defconfig | 1 + configs/socfpga_de0_nano_soc_defconfig | 1 + configs/socfpga_mcvevk_defconfig | 1 + configs/socfpga_sockit_defconfig | 1 + configs/socfpga_socrates_defconfig | 1 + configs/socfpga_sr1500_defconfig | 1 + configs/spear300_defconfig | 1 + configs/spear300_nand_defconfig | 1 + configs/spear300_usbtty_defconfig | 1 + configs/spear300_usbtty_nand_defconfig | 1 + configs/spear310_defconfig | 1 + configs/spear310_nand_defconfig | 1 + configs/spear310_pnor_defconfig | 1 + configs/spear310_usbtty_defconfig | 1 + configs/spear310_usbtty_nand_defconfig | 1 + configs/spear310_usbtty_pnor_defconfig | 1 + configs/spear320_defconfig | 1 + configs/spear320_nand_defconfig | 1 + configs/spear320_pnor_defconfig | 1 + configs/spear320_usbtty_defconfig | 1 + configs/spear320_usbtty_nand_defconfig | 1 + configs/spear320_usbtty_pnor_defconfig | 1 + configs/spear600_defconfig | 1 + configs/spear600_nand_defconfig | 1 + configs/spear600_usbtty_defconfig | 1 + configs/spear600_usbtty_nand_defconfig | 1 + configs/x600_defconfig | 1 + drivers/i2c/Kconfig | 25 ++++++++ drivers/i2c/designware_i2c.c | 9 +++ drivers/i2c/fsl_i2c.c | 379 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---------------------------------------- drivers/i2c/i2c-cdns.c | 132 ++++++++++++++++++++++++++-------------- drivers/i2c/muxes/Kconfig | 10 ++++ drivers/i2c/muxes/Makefile | 1 + drivers/i2c/muxes/pca954x.c | 79 ++++++++++++++++++++++++ drivers/i2c/mvtwsi.c | 62 +++++++++---------- include/configs/axs101.h | 1 - include/configs/socfpga_common.h | 1 - include/configs/spear-common.h | 1 - include/configs/x600.h | 1 - 47 files changed, 550 insertions(+), 231 deletions(-) create mode 100644 drivers/i2c/muxes/pca954x.c
bye, Heiko