
Wolfgang Denk wrote:
In message 41E4657F.6010406@orkun.us you wrote:
I will pledge for clarity over 6 more bytes in environment which most boards will not define anyway. If that is not reasonable, please allow for "tftpsrcport" or "tftpcport".
So be it "tftpsrcport" then. Or "tftpsrcp" :-)
I prefer "tftpsrcport". I hope Jerry will agee as well.
["tftpcport" ??? TFT-PC-Port? Or 'c' like what???]
'c' was to stand for "client". Just like bootpc and bootps in /etc/services
I actually want to provide a complimentary patch over this one to make the tftp server port configurable which the environment variable can be appropriately named as one of "tftpserverport", "tftpdestport" or
tftpdstport or tftpdstp, please.
IMHO, "tftpdstport" is better.
"tftpsport". I also want to use the same CONFIG_TFTP_PORT variable to
[Seems to be some funny kind of exercise, this: TFTP sport. And is misleading - TFTP _S_ource Port ?]
Yes, that is kind of vague. Again, I used bootpc and bootps analogy.
enable both environment variables unless you object in which case naming the config variables as CONFIG_TFTP_CLIENT_PORT and CONFIG_TFTP_SERVER_PORT is probably better.
OK.
OK for which? OK to use CONFIG_TFTP_PORT for enabling code for both "tftpsrcport" and "tftpdstport"?
Best regards, Tolunay