
Hi!
-ifdef CONFIG_CMD_USB +ifdef CONFIG_USB
Shouldn't this be a separate change ?
Do you mean a separate patch set or its own patch? I was actually not 100% sure about this one but ran into link problems with the status quo. It seemed odd that this code would depend on the USB command. Maybe you can elaborate a little?
obj-y += usb.o usb_hub.o obj-$(CONFIG_USB_STORAGE) += usb_storage.o endif diff --git a/drivers/usb/Kconfig b/drivers/usb/Kconfig index 4fbe172e05..03746dd12f 100644 --- a/drivers/usb/Kconfig +++ b/drivers/usb/Kconfig @@ -47,6 +47,11 @@ config DM_USB declared with the U_BOOT_USB_DEVICE() macro and will be automatically probed when found on the bus.
+config SPL_DM_USB
I think this should be introduced last, after all the core changes, since this patch won't compile cleanly on it's own, will it ?
Not sure, I understand. Just introducing a new Kconfig variable won’t change the “compilibility” of existing code?!
Best, Sven