
On 09:07 Fri 29 May , Dirk Behme wrote:
Hi riverful,
Kim, Heung Jun wrote:
Thanks to point. Dirk.
And call me "riverful" next time, plz :)
Kim mentioned that he shuffles around the code due to compile errors while adding his new code. So we have to see if we can stay with the current implementation or have to change something.
Yes. I shuffles around a little now.
Kim: What compile errors do you get for cache_flush()? Could you check if you really don't need it? Why don't you get compile errors if you move it from cpu/arm_cortexa8/cpu.c to lib_arm/cache-cp15.c?
The compile errors are two.
- First error occured cause of omap3 dependent definition CPU_3XX_ES20.
cpu.c:99: warning: function declaration isn't a prototype cpu.c: In function 'l2cache_enable': cpu.c:104: warning: implicit declaration of function 'get_cpu_rev' cpu.c:104: error: 'CPU_3XX_ES20' undeclared (first use in this function) cpu.c:104: error: (Each undeclared identifier is reported only once cpu.c:104: error: for each function it appears in.) cpu.c: At top level: cpu.c:129: warning: function declaration isn't a prototype cpu.c: In function 'l2cache_disable': cpu.c:134: error: 'CPU_3XX_ES20' undeclared (first use in this function) make[1]: *** [cpu.o] Error 1
Ok, this looks to me that we have to move l2cache_enable() and l2cache_disable() to cpu/arm_cortexa8/omap3/board.c and rename them to cortexa8_l2cache_enable()/disable() as asked in
<snip>
This is new and not discussed anywhere on this list already?
So to summarize my understanding:
We have to:
a) move l2cache_enable() and l2cache_disable()
move I agree rename no
we need to move the l2cache_XXXXX to cpu/$(ARCH)/$(SOC)/cache.c
b) keep cache_flush() as it is
c) talk about start.S
I'll propose a patch during the WE
Best Regards, J.