
Hi Igor,
2011/12/15 Igor Grinberg grinberg@compulab.co.il:
Where does it say that only this one is supported in the code?
You mean comments or the code?
Well the filename seems generic and not specific to that chip. Are viewports something that other chips can support?
Let me clarify:
- It is not the chip it is the controller (IP block) inside the SoC.
- viewport is just the register name inside the SoC that provides
and interface of the controller to access the ULPI PHY.
I think every SoC that uses that controller has the viewport setup this way, but I might be wrong (and that's why the viewport is separated from the generic ULPI spec implementation).
Regarding the name... yeah it could be renamed, but it follows Linux naming currently and it is the first one submitted, so IMO it can be named that generically.
COBJS-$(CONFIG_USB_ULPI) += ulpi.o COBJS-$(CONFIG_USB_ULPI_VIEWPORT) += ulpi-viewport.o
It would be good if you could mention the two new CONFIG options in the README.
I did, see below...
What is specific to that device?
The viewport bits? It is not a part of the ULPI spec. Other vendors do not have to comply with those. For example PXA310 has those bits placed and named in some other way...
OK I didn't realise that.
I think same stand for OMAP, but I'm not sure. OMAP still does arbitrary register writes for accessing ULPI.
- To enable the ULPI layer support, define CONFIG_USB_ULPI and
- CONFIG_USB_ULPI_VIEWPORT in your board configuration file.
Here the configs are documented. I admit, it is not that brilliant documentation...
Are you planning to post an update of this patch? The rest of the series I already pulled into the USB tree.
Kind regards,
Remy