
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
On 03/10/2014 01:24 PM, Stephen Warren wrote:
On 03/05/2014 09:45 AM, Przemyslaw Marczak wrote:
Changes: Move functions:
- disk/part_efi.c uuid_string() to lib/uuid.c -> uuid_bin_to_str()
- disk/part_efi.c string_uuid() to lib/uuid.c -> uuid_str_to_bin()
Update files:
- include/common.h
- disk/part_efi.c
- lib/Makefile
That's not a particularly useful patch description. How about:
Move uuid<->string conversion functions into lib/uuid.c so they can be used by code outside part_efi.c. Rename uuid_string() to uuid_bin_to_str(), so that's the naming is consistent with the existing uuid_str_to_bin(). Add an error return code to uuid_str_to_bin(). Convert existing users to the new library functions.
This one patch, Acked-by: Stephen Warren swarren@nvidia.com
As I'm applying and testing this locally right now, I'll take that better wording (and ack), thanks!
diff --git a/lib/Makefile b/lib/Makefile
obj-$(CONFIG_BOOTP_PXE) += uuid.o +obj-$(CONFIG_PARTITION_UUIDS) += uuid.o
Oh, I hope listing uuid.o twice in obj-y won't cause any issue...
Nope, we're good, it gets filtered now. We should handle this better once we have Kconfig in, but, one step at a time.
- -- Tom