
This patchset cleans the QEMU fw_cfg code:
*) split qfw core and qfw command interface *) split x86 specific operations from qfw core *) move x86 ACPI generation code into qfw core as this can also be used by others like ARM64 *) various cleanups
Changes in v2:
*) make git format-patch detect renames *) add a patch to enable qfw for sandbox_defconfig *) address other trivial review comments
Miao Yan (14): x86: qemu: fix ACPI Kconfig options cmd: qfw: add API to iterate firmware list cmd: qfw: remove qemu_fwcfg_free_files() cmd: qfw: make fwcfg_present and fwcfg_dma_present public x86: qemu: split qfw command interface and qfw core x86: qemu: move x86 specific operations out of qfw core x86: qemu: add comment about qfw register endianness cmd: qfw: rename qemu_fw_cfg.[c|h] to qfw.[c|h] cmd: qfw: do not require default macros when building qfw command cmd: qfw: do not depend on x86 cmd: qfw: bring ACPI generation code into qfw core x86: qemu: rename qemu/acpi_table.c cmd: qfw: rename QEMU_FW_CFG to CMD_QFW config: sandbox: enable qfw and cmd_qfw for testing
arch/x86/Kconfig | 10 +- arch/x86/cpu/mp_init.c | 6 +- arch/x86/cpu/qemu/Makefile | 4 +- arch/x86/cpu/qemu/cpu.c | 2 +- arch/x86/cpu/qemu/e820.c | 43 ++++ arch/x86/cpu/qemu/qemu.c | 50 ++++- arch/x86/lib/Makefile | 2 +- cmd/Kconfig | 4 +- cmd/Makefile | 2 +- cmd/{qemu_fw_cfg.c => qfw.c} | 189 ++--------------- configs/qemu-x86_defconfig | 2 +- configs/sandbox_defconfig | 2 + drivers/misc/Kconfig | 6 + drivers/misc/Makefile | 1 + .../cpu/qemu/acpi_table.c => drivers/misc/qfw.c | 223 +++++++++++++++++---- include/{qemu_fw_cfg.h => qfw.h} | 28 ++- 16 files changed, 336 insertions(+), 238 deletions(-) create mode 100644 arch/x86/cpu/qemu/e820.c rename cmd/{qemu_fw_cfg.c => qfw.c} (54%) rename arch/x86/cpu/qemu/acpi_table.c => drivers/misc/qfw.c (57%) rename include/{qemu_fw_cfg.h => qfw.h} (84%)