
On Mon, Jan 06, 2025 at 07:31:56AM -0700, Simon Glass wrote:
The current UPL spec[1] has been tidied up and improved over the last year, since U-Boot's original UPL support was written.
This series includes some prerequisite patches needed for the real UPL patches. It is split from [2]
[1] git@github.com:UniversalPayload/spec.git commit 3f1450d [2] https://patchwork.ozlabs.org/project/uboot/list/?series=438574&state=*
Changes in v2:
- Fix 'Emable' typo
- Enable the command in cmd/Kconfig instead
- Fix unbalanced {}
- Add new patch to move x86 tables to use SZ macros
- Use 4K instead of 4KB
- Add new patch to enable bloblist on x86
- Split this into its own function
- Split prerequisite patches into their own series
Raymond Mao (1): bloblist: add api to get blob with size
Simon Glass (32): bloblist: Drop BSD license bloblist: Make BLOBLIST_ALLOC the default abuf: Provide a way to get the buffer address abuf: Allow use in host tools abuf: Provide a constant buffer cpu: Provide a way to get the physical-address size serial: Support info() method in ns16550 xPL with UPL mkimage: Update map_to_sysmem() to match its prototype x86: Enable meminfo command x86: Show the timestamp counter with bdinfo ofnode: Use 4K for a default tree-size ofnode: Indicate when out of space in a few places ofnode: Update of_add_subnode() to indicate name is alloced boot: Rename fit_image_get_data() boot: Rename fit_image_get_data_and_size() boot: Update fit_image_get_emb_data to use abuf boot: Use fit_image_get_data() to get data boot: Update fit_image_get_data() to use abuf test: Fix inpected typo in upl test emulation: fdt: Relax condition for OF_HAS_PRIOR_STAGE emulation: Use bloblist to hold tables x86: Create more space for SPL with qemu-x86_64 pci: video: Set up the pixel-format field x86: Show an error if video fails x86: Support jumping to a UPL image x86: Enable UPL handoff for SPL x86: Move tables to use SZ macros x86: Align the SMBIOS table to a 4K boundary x86: emulation: Enable bloblist dm: core: Clarify behaviour of ofnode_name_eq() dm: core: Provide ofnode_name_eq_unit() to accept a unit address dm: core: Provide ofnode_find_subnode_unit()
Setting aside the bloblist parts of this. The x86 parts (and pci: video) are likely fine. I've commented about abuf now. I'm not keen, but I'm not nak'ing all of the rename stuff. All of the dm stuff is still you, and it doesn't look like there's anything behavior changing there, so that's fine. The rest of the QEMU related stuff needs a think.