
On Mon, Sep 19, 2016 at 05:44:09PM +0200, Hans de Goede wrote:
Hi,
On 19-09-16 17:00, Tom Rini wrote:
On Mon, Sep 19, 2016 at 04:53:04PM +0200, Hans de Goede wrote:
Hi,
On 19-09-16 16:03, Tom Rini wrote:
Based on A13-OLinuXino, enable DFU and UMS support.
Signed-off-by: Tom Rini trini@konsulko.com
With this change I've added DFU to my tests on this board, and assuming a follow up test with the SD image that kicks the board into FEL works, I'll then enable the UMS tests on this board (and add DFU to SD, not just DFU to RAM).
configs/A20-OLinuXino-Lime2_defconfig | 8 ++++++++ 1 file changed, 8 insertions(+)
diff --git a/configs/A20-OLinuXino-Lime2_defconfig b/configs/A20-OLinuXino-Lime2_defconfig index 23db07380624..54343de7f351 100644 --- a/configs/A20-OLinuXino-Lime2_defconfig +++ b/configs/A20-OLinuXino-Lime2_defconfig @@ -12,9 +12,17 @@ CONFIG_SYS_EXTRA_OPTIONS="SUNXI_GMAC,RGMII,AHCI,SATAPWR=SUNXI_GPC(3)" CONFIG_SPL=y # CONFIG_CMD_IMLS is not set # CONFIG_CMD_FLASH is not set +CONFIG_CMD_DFU=y +CONFIG_CMD_USB_MASS_STORAGE=y
Do you need CMD_USB_MASS_STORAGE for your tests ? Enabling CMD_USB_MASS_STORAGE really seems orthogonal to enabling GADGET mode to me, esp. since it is only useful in host mode AFAICT.
Ah, no, things have bad names perhaps. CMD_USB_MASS_STORAGE enables "ums" as a command which is what in turn will export MMC (or something else) as a USB mass storage gadget over to the host.
Ah, I thought this enabled the (destructive) low level usb mass storage block read/write test commands, but I guess I'm wrong.
I wonder why Chen-Yu put it in the usb host enabling patch for an A33 board then...
Chen-Yu did something similar in a patch enabling host mode for a different sunxi board and here is what I replied:
" If we want to enable CONFIG_CMD_USB_MASS_STORAGE on sunxi, we really should do so on all boards (feel free to submit a patch for this).
e.g. add something like this to board/sunxi/Kconfig:
config CMD_USB_MASS_STORAGE default y
Given the above, that should probably be:
config CMD_USB_MASS_STORAGE default y if USB_GADGET
Hmm, I guess we may want to have a bunch of those, so that simply adding:
CONFIG_USB_MUSB_GADGET=y
To a defconfig enables the relevant related options...
Yes. I think that something that should be done, and sooner rather than later, is changing more options from 'default n' (the default when not spelled out) to 'default y' as with the change from board.h to Kconfig there is much less pain in turning off default values. Things like 'ums' are really handy and unlike DFU/fastboot don't require additional configuration. So, I should go and fire off a patch for this one quickly at least.