
On 12/14/11 21:26, Simon Glass wrote:
Hi Igor,
On Tue, Dec 13, 2011 at 9:51 PM, Igor Grinberg grinberg@compulab.co.il wrote:
Hi Simon,
On 12/14/11 02:28, Simon Glass wrote:
Hi Igor,
On Mon, Dec 12, 2011 at 2:08 AM, Igor Grinberg grinberg@compulab.co.il wrote:
Add documentation for CONFIG_USB_ULPI and CONFIG_USB_ULPI_VIEWPORT configuration options.
Signed-off-by: Igor Grinberg grinberg@compulab.co.il
README | 8 ++++++++ 1 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/README b/README index ff72e47..6fe1e0f 100644 --- a/README +++ b/README @@ -1185,6 +1185,14 @@ The following options need to be configured: for your device - CONFIG_USBD_PRODUCTID 0xFFFF
+- ULPI Layer Support:
The ULPI (UTMI Low Pin (count) Interface) PHYs are supported via
the generic ULPI layer. The generic layer accesses the ULPI PHY
via the platform viewport, so you need both the genric layer and
the viewport enabled. Currently only Chipidea/ARC based
viewport is supported.
Where does it say that only this one is supported in the code?
You mean comments or the code?
Well the filename seems generic and not specific to that chip. Are viewports something that other chips can support?
Let me clarify: 1) It is not the chip it is the controller (IP block) inside the SoC. 2) viewport is just the register name inside the SoC that provides and interface of the controller to access the ULPI PHY.
I think every SoC that uses that controller has the viewport setup this way, but I might be wrong (and that's why the viewport is separated from the generic ULPI spec implementation).
Regarding the name... yeah it could be renamed, but it follows Linux naming currently and it is the first one submitted, so IMO it can be named that generically.
COBJS-$(CONFIG_USB_ULPI) += ulpi.o COBJS-$(CONFIG_USB_ULPI_VIEWPORT) += ulpi-viewport.o
It would be good if you could mention the two new CONFIG options in the README.
I did, see below...
What is specific to that device?
The viewport bits? It is not a part of the ULPI spec. Other vendors do not have to comply with those. For example PXA310 has those bits placed and named in some other way...
OK I didn't realise that.
I think same stand for OMAP, but I'm not sure. OMAP still does arbitrary register writes for accessing ULPI.
To enable the ULPI layer support, define CONFIG_USB_ULPI and
CONFIG_USB_ULPI_VIEWPORT in your board configuration file.
Here the configs are documented. I admit, it is not that brilliant documentation...