
On Sun, Sep 24, 2023 at 01:24:53PM -0600, Simon Glass wrote:
For U-Boot proper we have CONFIG_SYS_MALLOC_F which indicates that a malloc() pool is available before relocation.
For SPL we only have CONFIG_SPL_SYS_MALLOC_F_LEN which indicates the size of the pool.
In various places we use CONFIG_SPL_SYS_MALLOC_F_LEN == 0 to indicate that there is no pool.
This differing approach is confusing. Add a new CONFIG_SPL_SYS_MALLOC_F symbol for SPL (and similarly for TPL and VPL). Tidy up the Kconfig help for clarity.
For now these symbols are not used. That is cleaned up in the following patches.
Signed-off-by: Simon Glass sjg@chromium.org
This introduces:
WARNING: unmet direct dependencies detected for SPL_SYS_MALLOC_F Depends on [n]: ARM [=y] && ARCH_SNAPDRAGON [=n] || ARM [=y] && ARCH_SOCFPGA [=n] || SPL_FRAMEWORK [=n] && SYS_MALLOC_F [=y] && SPL [=y] Selected by [y]: - SPL_DM_SERIAL [=y] && SERIAL [=y] && DM_SERIAL [=y] && SPL_DM [=y]
WARNING: unmet direct dependencies detected for SPL_SYS_MALLOC_F Depends on [n]: ARM [=y] && ARCH_SNAPDRAGON [=n] || ARM [=y] && ARCH_SOCFPGA [=n] || SPL_FRAMEWORK [=n] && SYS_MALLOC_F [=y] && SPL [=y] Selected by [y]: - SPL_DM_SERIAL [=y] && SERIAL [=y] && DM_SERIAL [=y] && SPL_DM [=y]
On mx28evk and imx28_xea_sb.