
Hello Wolfgang
Before this "unification" patch I send another path that did treat the avnet board as a new board (a lot of code replication). This is what I call the old way.
Let me be more clear. What do we want:
MODE A =========
ml507_config: unconfig BOARD_DIR=$(obj)board/xilinx/ml507 \ TEXT_BASE=0x3000000 \ LINK_SCRIPT=$(obj)board/xilinx/ppc440-generic/u-boot-ram.lds \ CONFIG_SCRIPT="ml507 ppc ppc4xx ml507 xilinx" \ $(MAKE) xilinx_ppc440
ml507_flash_config: unconfig BOARD_DIR=$(obj)board/xilinx/ml507 \ TEXT_BASE=0xFE360000 \ LINK_SCRIPT=$(obj)board/xilinx/ppc440-generic/u-boot-rom.lds \ CONFIG_SCRIPT="ml507 ppc ppc4xx ml507 xilinx" \ $(MAKE) xilinx_ppc440
v5fx30teval: LIKE BEFORE
v5fx30teval_flash: LIKE BEFORE
xilinx_ppc440: unconfig @mkdir -p $(obj)include $(BOARD_DIR) @cp $(LINK_SCRIPT) $(BOARD_DIR)/u-boot.lds @echo "TEXT_BASE = $(TEXT_BASE)" > $(BOARD_DIR)/config.mk @$(MKCONFIG) $(CONFIG_SCRIPT)
MODE B ==========
ml507: unconfig @mkdir -p $(obj)include $(obj)board/xilinx/ml507 @cp $(obj)board/xilinx/ppc440-generic/u-boot-rom.lds $(obj)board/xilinx/ml507/u-boot.lds @echo "TEXT_BASE = 0x30000000" > $(obj)board/xilinx/ml507/config.mk @$(MKCONFIG) ml507 ppc ppc4xx ml507 xilinx
ml507_flash: unconfig @mkdir -p $(obj)include $(obj)board/xilinx/ml507 @cp $(obj)board/xilinx/ppc440-generic/u-boot-rom.lds $(obj)board/xilinx/ml507/u-boot.lds @echo "TEXT_BASE = 0x30000000" > $(obj)board/xilinx/ml507/config.mk @$(MKCONFIG) ml507 ppc ppc4xx ml507 xilinx
v5fx30teval: LIKE BEFORE
v5fx30teval_flash: LIKE BEFORE
MODE C ======== Please write your suggestion here.
My opinion:
Mode A is more "magical": it calls the make program again, but it is easier to maintain and has less code duplication: There are 6 boards that have to be configured the same way. Nevertheless is your/Stefan choose.
Regards
On Fri, Aug 29, 2008 at 17:01, Wolfgang Denk wd@denx.de wrote:
Dear "Ricardo Ribalda Delgado",
In message aa76a2be0808290451w33492233l6cb0f66ec22a1ab2@mail.gmail.com you wrote:
I have no problem in setting the Makefile in the classic way, I just wanted to create a new way with the less code replication possible.
Shall I continue with this idea or I move back to the old way?
I'm not sure if I really understand what the "old" and the "new" way is, but we must limit the growth of the Makefile; it is not a place to configura boards. Yes, this has been done in the past (when U-Boot supported only a fraction of the boards we have today), and maybe we even clean up the old boards one day, but at least don't let us add more of this stuff.
Best regards,
Wolfgang Denk
-- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd@denx.de "It takes all sorts of in & out-door schooling to get adapted to my kind of fooling" - R. Frost