
On 17 December 2014 at 07:41, Simon Glass sjg@chromium.org wrote:
On 17 December 2014 at 00:50, Bin Meng bmeng.cn@gmail.com wrote:
This is the follow-on patch to clean up the FSP support codes:
- Remove the _t suffix on the structures defines
- Use __packed for structure defines
- Use U-Boot's assert()
- Use standard bool true/false
- Remove read_unaligned64()
- Use memcmp() in the compare_guid()
- Remove the cast in the memset() call
- Replace some magic numbers with macros
- Use panic() when no valid FSP image header is found
- Change some FSP utility routines to use an fsp_ prefix
- Add comment blocks for asm_continuation and fsp_init_done
- Remove some casts in find_fsp_header()
- Change HOB access macros to static inline routines
- Add comments to mention find_fsp_header() may be called in a stackless environment
- Add comments to mention init(¶ms) in fsp_init() cannot be removed
Signed-off-by: Bin Meng bmeng.cn@gmail.com
Changes in v4:
- Use __packed for structure defines
- Fix some typos and print FSP full name in cmd_hob.c
Changes in v3: None Changes in v2:
- Remove some casts in find_fsp_header()
- Change HOB access macros to static inline routines
arch/x86/cpu/queensbay/fsp_configs.c | 2 +- arch/x86/cpu/queensbay/fsp_support.c | 253 ++++++++++----------- arch/x86/cpu/queensbay/tnc_dram.c | 18 +- arch/x86/include/asm/arch-queensbay/fsp/fsp_api.h | 18 +- arch/x86/include/asm/arch-queensbay/fsp/fsp_ffs.h | 28 +-- arch/x86/include/asm/arch-queensbay/fsp/fsp_fv.h | 14 +- arch/x86/include/asm/arch-queensbay/fsp/fsp_hob.h | 112 +++++---- .../asm/arch-queensbay/fsp/fsp_infoheader.h | 6 +- .../include/asm/arch-queensbay/fsp/fsp_platform.h | 8 +- .../include/asm/arch-queensbay/fsp/fsp_support.h | 63 ++--- .../x86/include/asm/arch-queensbay/fsp/fsp_types.h | 17 +- arch/x86/include/asm/arch-queensbay/fsp/fsp_vpd.h | 8 +- arch/x86/lib/cmd_hob.c | 22 +- 13 files changed, 279 insertions(+), 290 deletions(-)
Acked-by: Simon Glass sjg@chromium.org
Applied to u-boot-x86, thanks!