
8 Sep
2010
8 Sep
'10
5:43 a.m.
Dear Wolfgang Denk,
- /* linebuf as a union causes proper alignment */
- union linebuf {
uint32_t ui[MAX_LINE_LENGTH_BYTES/4 + 1];
uint16_t us[MAX_LINE_LENGTH_BYTES/2 + 1];
uint8_t uc[MAX_LINE_LENGTH_BYTES/1 + 1];
Please replace the magic numbers 4, 2 and 1 by respective sizeof().
AND
Please let's use the attribute version.
Which shall it be now???
Best Regards, Reinhard