
Hi Stephen,
On Fri, 01 Aug 2014 12:36:22 -0600 Stephen Warren swarren@wwwdotorg.org wrote:
Or you may rename CONFIG_TARGET_JETSON_TK1 to CONFIG_BOARD_JETSON_TK1 or another name.
I don't want to force CONFIG_TARGET_ name convention. You can change config names if you like. It is up to you.
I assume you don't object to the current patch, but were just pointing out that I could rename the variable if I wanted?
I do not object to this patch at all. Yes, I just pointed out it just in case.
All the configs/${board}_defconfig I looked at use CONFIG_TARGET_${board}, so I think it's best if I just convert the code to using that so everything is consistent.
...
When I see Tegra family, each board has its own config header. CONFIG_BOARD_ as well as CONFIG_TARGET_ will work.
AFAIK, only Jetson TK1 used a custom CONFIG_BOARD_xxx variable. I only did that because it shares some code with Venice2 and needed to define some variable do distinguish the two boards, and there wasn't already a standard variable for this in the build process. I'm quite happy to convert to the standard (or even de-facto) standard variable we have now.
This might be rahter an open question, but I was just wondering which prefix is nice for choosing a board.
- CONFIG_BOARD_*
This seems clear prefix for board select. But we will have the name space conflict with exsting macros such as CONFIG_BOARD_LATE_INIT, CONFIG_BOARD_EARLY_INIT_F, etc.
- CONFIG_TARGET_*
The current implementation is using this.
- CONFIG_MACH_*
ARM Linux adopts this name rule and I can see various headers are using it.
Best Regards Masahiro Yamada