
On Wed, 7 Jan 2015 14:47:36 -0500 Tom Rini trini@ti.com wrote:
On Thu, Dec 18, 2014 at 04:13:48PM +0900, Masahiro Yamada wrote:
Hi Tom,
On Wed, 10 Dec 2014 20:34:03 -0500 Tom Rini trini@ti.com wrote:
On Thu, Dec 11, 2014 at 10:01:38AM +0900, Masahiro Yamada wrote:
If CONFIG_SPL_NOR_SUPPORT is defined, spl_nor_load_image() requires spl_start_uboot(), CONFIG_SYS_OS_BASE, CONFIG_SYS_SPL_ARGS_ADDR, CONFIG_SYS_FDT_BASE to be defined even if users just want to run U-Boot, not Linux. This is inconvenient.
Signed-off-by: Masahiro Yamada yamada.m@jp.panasonic.com
Good idea, but the function to check on U-Boot or Linux should be called spl_start_uboot to match the other load methods :)
I think I am following this way.
+#if defined(CONFIG_SPL_OS_BOOT) +int load_linux(void) +{
- if (spl_start_uboot())
return -1;
Here. Any problem?
Yes, it should look like spl_nand_load_image().
OK.
I generally prefer to dividing shorter helper functions and shaller nests, but common/spl/spl_nand.c is what you want, v2 is here: