
On Mon, Mar 2, 2020 at 6:40 PM Marek Vasut marex@denx.de wrote:
On 3/2/20 8:20 AM, Tan, Ley Foon wrote: Hi,
[...]
On 2/26/20 8:01 PM, Ley Foon Tan wrote: [...]
+#define BOOTROM_SHARED_MEM_ADDR
(CONFIG_SYS_INIT_RAM_ADDR + 0x40000 \
- 0x800)
+#define RST_STATUS_SHARED_ADDR
(BOOTROM_SHARED_MEM_ADDR + 0x438)
Are all these magic values needed or is there some more descriptive macro name available for them ?
0x40000 is onchip ram size and 0x800 is 2KB size. I can convert these to 2 macos.
Aren't those already defined in include/configs/socfpga_common.h ?
socfpga_common.h have this: #define CONFIG_SYS_INIT_RAM_SIZE (0x40000 - CONFIG_SYS_SPL_MALLOC_SIZE)
But, we can't use it here.
+u32 rst_mgr_status __section(.data);
static u32 ... ?
Other files might want to use this.
But they currently don't ? If others want to use it, they can remove the static then.
Okay.
Regards Ley Foon